Get the Excite Email Notifier!


You have chosen not to download Macromedia Flash.

PLEASE NOTE: The Excite Email Notifier is only compatible with
Web browsers that have Macromedia Flash installed. If you wish to
use the Excite Email Notifier, you must download Macromedia Flash.

Click here to download Macromedia Flash and the Excite Email Notifier

Click here to go to your Excite Start Page




Note: To use Excite Email Notifier your PC must be running Windows 95,
Windows 98, Windows Me, Windows NT 4.0, Windows 2000, or Windows XP.
For more details, see the Email Notifier FAQs.