Excite Message Boards
There was an error in accessing the Excite Message Boards

Entering the new Message Boards may have failed because:

 
  1. You do not have an operating system that is compatible. The new Excite Message Boards currently operate for Windows 95, Windows 98, Windows ME, Windows NT 4.0, Windows 2000, and the Mac Operating System. However, the new Excite Message Boards currently do not function with the WebTV interface.

  2. You have a browser version that is not compatible with the new Excite Message Boards. The new Excite Message Boards will work with the most recent versions of Internet Explorer and Netscape Navigator. The Excite Message Boards are fully compatible with Internet Explorer versions 4.0 and above. The Excite Message Boards are compatible with Netscape Navigator versions 4.0 through 4.72. The Excite Message Boards are not compatible with browser versions below 4.0 and currently are not compatible with Netscape 6.0.